Включить версию для слабовидящих Персональный сайт - алгоритмы
Размер шрифта: A A A Изображения Выключить Включить Цвет сайта Ц Ц Ц Х
Четверг, 29.06.2017, 12:07
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

алгоритмы

 

Линейные алгоритмы

Самые простые по структуре. Они не имеют ветвлений и циклов.

 

Пример 1.  Для двух целых чисел A и B записать на языке блок-схем алгоритм и  программу определения суммы S, разности R  и среднего арифметического SR

 

алг линейный алгоритм
нач
. цел A, B, S, R
. вещ SR
. вывод 'введите два целых числа'
. ввод A, B
. S:=A + B
. R:=A - B
. SR:=S/2
. вывод 'S=',S, 'R=',R, 'SR=',SR
кон

 

Пример 2. Поменяйте между собой значения переменных A и B без использования третьей переменной.

 

 

алг линейный алгоритм
нач
. цел A, B
. вывод 'введите два целых числа'
. ввод A, B
. A:=A+B
. B:=A-B
. A:=A-B
.
вывод 'A=', A, 'B=', B
кон

Пример 3. Переменным A и B присвоить значения: A:=A+B, B:=A-B.

алг переменным A и B присвоить A:=A+B, B:=A-B
нач
. цел A, B
. вывод 'введите два целых числа'
. ввод A, B\
. A:=A+B
. B:=A-2*B
. вывод 'A=', A, 'B=', B
кон

 

Пример 4.  Вводится натуральное двухзначное число A. Поменяв местами цифры числа A, сформировать число B и вывести абсолютную величину разности между  A и B. Записать программу и алгоритм решения задачи. 

алг цифры числа 
нач
. цел A, B, X, Y
. вещ R
. вывод 'введи натуральное двухзначное число'
. ввод A
. X := mod(A,10)
. Y := div(A,10)
. B := 10*X + Y
. R := abs(A - B)
. вывод 'B=',B, 'R=',R
кон

 

 

 

 

 


Copyright MyCorp © 2017