Включить версию для слабовидящих Персональный сайт - цикличекие
Размер шрифта: A A A Изображения Выключить Включить Цвет сайта Ц Ц Ц Х
Воскресенье, 25.06.2017, 01:24
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

цикличекие

 Циклические алгоритмы  с заранее известным числом повторений

Циклические алгоритмы строятся в соответствии с базовой алгоритмической структурой "цикл". В циклических алгоритмах некоторая часть операторов повторяет свои действия или заранее заданное число раз, или число раз, необходимое для получения результата. По этому признаку они условно делятся на алгоритмы  типа "для" и алгоритмы типа "пока". Первые еще называют циклическими  алгоритмами с заранее известным числом повторений или циклы со счетчиками. Вторые - с заранее неизвестным числом повторений, или циклы без счетчика. Последние делятся на алгоритмы с предусловием и алгоритмы с постусловием.

Циклические алгоритмы тип "для"
 

Параметр цикла:  N1-начальное значение,

N2 - конечное значение, N3 - шаг изменения.

   

Пример 1.  Запись  алгорита и программы определения суммы чисел от 3 до 99 кратных 3.

 

Блок-схема алгоритма

 

Программа

алг сумма кратных трем 
нач
 цел X, S=0
 нц для X от 3 до 99 шаг 3
  S:=S + X
 кц
 вывод 'сумма чисел кратных трем=',S 
кон

Пример 2. С клавиатуры вводится шестиразрядное натуральное число X. Программа выводит сумму S и произведение P цифр этого числа.

 

Блок - схема алгоритма

Программа
алг сумма цифр
нач
 цел X, S=0, i, A
 вещ P=1
 вывод 'введи шестирязрядное число'
 ввод X
 нц для i от 1 до 6 
  A := mod(X,10)
  S:=S + A
  P:=P*A
  X :=div(X,10)
 кц
 вывод 'сумма цифр числа X = ',S, нс
 вывод 'Произведение цифр числа X = ', P 
кон

Copyright MyCorp © 2017