Персональный сайт - циклические алгоритм пока
Суббота, 18.11.2017, 00:03
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

                             Главная Регистрация Вход
Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

циклические алгоритм пока

Циклические алгоритмы с заранее неизвестным числом повторений

 

 

Пример 1. Записать алгоритм и программу суммирования натуральных чисел 1, 2, 3, ..., пока их сумма s не станет равной или превысит величину h. Вывести на экран дисплея последнее слагаемое и значение суммы.

 

алг сумма натурвльных чисел
нач
. цел a = 0, h, s=0
. вывод ' введи число h'
. ввод h
. нц пока s < h
. . a := a + 1
. . s := s + a
. кц
. вывод 'сумма натуральных чисел ', s

. вывод ' последнее слагаемое ', a
кон

Пример 2. Записать программу и алгоритм определения номера первого члена геометрической прогрессии 2, 4, 8, 16,..., первым превысившего число z.

 

алг вклад
нач
. цел k = 0, p, s
. вещ Q, v, w
. вывод 'введи сумму вклада'
. ввод v
. вывод 'годовую процентную ставку банкаэ за год'
. ввод p
. вывод 'введи требуемую сумму'
. ввод s
. w := v
. нц пока s > v
. . Q := v*p/100
. . v := v+q
. . k := k + 1
. кц
. вывод 'При вкладе w=', w, 'Сумма ', s, 'будет накоплена за', k, 'лет'
кон

   

 


Copyright MyCorp © 2017