Включить версию для слабовидящих Персональный сайт - двухмерные массивы
Размер шрифта: A A A Изображения Выключить Включить Цвет сайта Ц Ц Ц Х
Четверг, 29.06.2017, 17:04
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

двухмерные массивы

Двухмерные массивы

 

Для формирования и вывода двухмерного массива используются вложенные циклы. Показанный код программы решает следующую задачу. С помощью генератора случайных чисел создается и выводится в виде таблицы двухмерный массив целых чисел a[1:4, 1:4], рассчитывается сумма каждой строки, из сумм строк формируется одномерный массив b[1:4] и выводится на печать. Справа представлен один из вариантов вывода результата работы алгоритма.

алг сумма строк
нач
. цел ij,  s
. целтаб a[1:4, 1:4]
. целтаб b[1:4]
. нц для i от 1 до 4
. . s := 0
. . нц для j от 1 до 4
. . . a[i, j] := irand(-5, 10)
. . . s := s+a[ij]
. . . вывод a[ij], '   '
. . кц
. . вывод нс
. . b[i] := s
. кц
. нц для i от 1 до 4
. . вывод 'b[', i, ']=', b[i], '   '
. кц

кон

-5 9 7 -2  

0 0 0 4

-4 1 0 5

0 -4 5 9

b[1]=9 b[2]=4 b[3]=2 b[4]=10

 

Примеры алгоритмов, реализуемых с помощью вложенных циклов типа ДЛЯ

 

 


Copyright MyCorp © 2017