Персональный сайт - массивы
Суббота, 23.09.2017, 22:58
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

Меню сайта
Статистика

Онлайн всего: 2
Гостей: 2
Пользователей: 0

массивы

Циклические алгоритмы с заранее известным числом повторений

Массивы

Массивы - это объединенное одним именем (идентификатором массива) множество однотипных элементов. К основным параметрам массива относятся его тип (числовой, строковый, логический), размерность (одномерный, двухмерный, трехмерный и т. д.) и размер (количество элементов массива в каждом измерении).

Виды записи массива: целтаб R[1:N], где N - максимальный номер массива, R - имя массива, целтаб-тип массива.

Пример 1. Задан массив целых чисел. Записать алгоритм и программу определения суммы элементов массива и количество положительных элементов.

Блок - схема алгоритм

 

Программа

 


 

алг массив сумма 
нач
 цел i, s=0, k=0
 целтаб a[1:7]
 a[1]:=-3
 a[2]:=6
 a[3]:=-4 
 a[4]:=0 
 a[5]:=3 
 a[6]:=5 

 a[7]:=-2
 нц для i от 1 до 7
   s := s+a[i]
   если a[i] >0 то
    k:=k + 1
   все
 кц
 вывод 'сумма элементов массива s= ', s, нс
 вывод 'количество положительных элементов k= ', k
ко
н

Пример 2. Записать алгоритм и программу определения в массиве целых чисел a[1:n] среднего арифметического чисел превышающих значение d. Эле­мен­ты мас­си­ва могут при­ни­мать целые зна­че­ния от –100 до 100. Для ввода массива использовать генератор случайных чисел.

 

Программа

алг массив сумма 
нач
  цел i, s=0, k=0, n, d
  вещ sr
  вывод 'введи количество элементов в массиве'
  ввод n

  целтаб a[1:n]
  вывод 'введи d'
  ввод d
  нц для i от 1 до n
    a[i]:= irand(-100,100)
    вывод 'a[',i,']= ',a[i],' '
  кц
  нц для i от 1 до n

    если a[i] >d то
     k:=k + 1
     s := s+a[i]
    все
  кц
  вывод нс
  sr:=s/k

  вывод 'среднее арифметическое sr ', sr
кон

 


Copyright MyCorp © 2017