Персональный сайт - ветвление
Суббота, 18.11.2017, 00:02
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

                             Главная Регистрация Вход
Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

ветвление

Ветвящиеся алгоритмы

Ветвящиеся алгоритмы содержат блок "решение", который может иметь два и более альтернативных выходов. При работе алгоритма в зависимости от выполнения условий выбирается один из этих выходов, и выполняются соответствующие ему действия.

Полная форма ветвления Неполная форма ветвления
   

Примеры решения задач

Пример 1. Вычислить значение величины C, определяемое по формулам: C = A + B,  если  A<=B и C = A - B, если  A<= B

Программа

Блок - схема алгоритма

алг полная форма ветвления
нач
. цел A, B, C
. вывод 'введи два числа'
. ввод A, B
. если A >= B то
. . . C := A - B
. . иначе
. . . C := A + B
. все
. вывод 'C =', C

кон

Пример 2. Заданы радиус круга R и сторона квадрата A. Определить, можно ли вписать квадрат в круг. Записать алгоритм и программу решения задачи.

 

Программа

Блок - схема алгоритма

алг 'можно ли вписать квадрвт в круг?'
нач
. цел A, R, D
. вещ B
. вывод 'введи радиус круга R и сторону квадрата A'
. ввод A, R
. B := sqrt(2*A**2)
. D := 2*R
. если D < B то
. . . вывод 'Квадрат нельзя вписать в круг '
. . иначе
. . . вывод ' Квадрат можно вписать в круг'
. все
кон

.

Пример 3.  При вводе двух чисел выводится одно из трех сообщений: первое число больше, второе число больше, числа равны.

Программа

Блок - схема алгоритма

алг Сравнение чисел по величине
нач
. цел A, B
. лит R
. вывод 'введи два числа'
. ввод A, B
. если A > B то
. . . R := 'Первое число больше'
. . иначе если A < B то
. . . . . R := 'Второе число больше'
. . . . иначе
. . . . . R := 'Числа равны'
. . . все
. все

кон

 


Copyright MyCorp © 2017