Включить версию для слабовидящих Персональный сайт - вложенные циклы
Размер шрифта: A A A Изображения Выключить Включить Цвет сайта Ц Ц Ц Х
Воскресенье, 25.06.2017, 01:29
Приветствую Вас Гость | RSS

МОУ СОСНОВСКИЙ ЦЕНТР ОБРАЗОВАНИЯ

Меню сайта
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

вложенные циклы

Вложенные циклы

Вложенным называют цикл, входящий в тело другого цикла. Вложенность может быть многократной. Рассмотрим алгоритм и программу создания таблицы умножения.

Программа Блок - схема алгоритма

алг таблица умножения
нач
. цел i, j
. нц для i от 1 до 9
. . нц для j от 1 до 9
. . . вывод  I * j, '  '
. . кц
. . вывод нс
. кц
кон

Внешний цикл с параметром i перебирает все номера строк таблицы умножения от 1 до 9. Для каждого номера строки во внутреннем цикле перебираются все номера столбцов j таблицы и выводится на экран произведение номера строки на номер столбца.

   
 Электронный учебник. Вложенный цикл. Теория
   

 


Copyright MyCorp © 2017